Slow Website
Incident Report for Loom
Resolved
This incident has been resolved.
Posted 12 months ago. Oct 15, 2018 - 20:26 UTC
Investigating
Website experienced a slowdown for a period of 60 minutes.
Posted about 1 year ago. Oct 14, 2018 - 21:00 UTC
This incident affected: Website & API.